Um thinkfan für die Lüfterverwaltung beim thinkpad verwenden zu können, muss man in der Config-Datei die entsprechenden Temperatursensoren eintragen. Bei mir sind das:

hwmon /sys/devices/virtual/hwmon/hwmon1/temp1_input
hwmon /sys/devices/virtual/hwmon/hwmon2/temp1_input
hwmon /sys/devices/platform/coretemp.0/hwmon/hwmon3/temp3_input
hwmon /sys/devices/platform/coretemp.0/hwmon/hwmon3/temp1_input
hwmon /sys/devices/platform/coretemp.0/hwmon/hwmon3/temp2_input

Problematisch: Bei einem Reboot änderten sich die Namen geringfügig, z.b. hwmon1 und 3 statt 0 und 2. Dadurch brach thinkfan nach jedem Reboot direkt nach dem Start mit einer Fehlermeldung ab, weil die eingetragenen Sensoren nicht gefunden werden konnten

Hier und hier kommt die Lösung her, mit der sich die Dateinamen nicht mehr ändern:

Mit Hilfe von sensors-detect die nötigen Kernelmodule herausfinden, die werden dann automatisch in /etc/conf.d/lm_sensors geschrieben. Anschließend genau diese Module dann "blacklisten", sodass sie nicht mehr automatisch geladen werden beim Systemstart und in der lm-sensors Konfigurationsdatei dann in einer festen Reihenfolge angeben, damit die Nummerierungen immer gleich bleiben.

Für das X250:

/etc/modprobe.d/thinkfan.conf

blacklist i2c-dev
blacklist cpuid
blacklist coretemp
blacklist i2c_i801

/etc/conf.d/lm_sensors

HWMON_MODULES="i2c-dev i2c_i801 cpuid coretemp"

HWMON_MODULES="i2c-dev i2c_i801 cpuid coretemp"

Dann Neustarten und die thinkfan.conf ein letztes mal den aktuellen Sensorennamen entsprechend anpassen.

So bleibt es bei mir stabil. Danke an die arch bbs und ubuntuforums.org für die Lösung.